
OBSERVING WITH PROEM CAMERA –
LIGHTFIELD
January 26, 2015

Introduction

Before going to the mountain, you cannot forget to bring an extra data storage (CDs, DVDs,
external HD, ...) as well as the list with all your target information. Of course, you should
know what you are aiming for, to minimize the chances of losing precious observing time.

Problems? Doubts?

In case anything happens, do not hesitate in calling Dave Doss (675 or 111) or the observing
support (Coyne 661 or 114, John 665). Check the telephone numbers in the control room
and the instructions to use the pager.

Keaton’s phone number: 206-370-1455. Sam’s phone number: 512-516-3464.

The afternoon

The observing fun starts early in the first afternoon prior the run. If this is the first night of
your first run, allow yourself some time for the set up before sunset. Your tasks as observer
are:

1. Power on ProEM. The switch button is on the East-side of the instrument. It will
take about 30 min to stabilize the temperature on the camera.

2. Set up computers

There are 2 computers (besides your own): windows computer and guide82 com-
puter.

Argos-dev computer is the acquisition computer. This computer should be on,
but if it is not, turn it on and boot into driver labeled Windows 7 Enterprise 64-bit.

(a) Open LightField (double-click on Desktop icon). It takes about 1/2 hour for
the camera to cool down to -55◦C.

(b) Load Experiment: click on folder icon (center icon, top left corner of LightField
software. (default experiment).

(c) Confirm that Domain Time II Client is running: Click Start menu > Control

Panel. Shift right click Domain Time II Client and Run as administrator.
Click Show details > yes. If Domain Time box is not running, click Start

Service. Close window.

1



(d) Open shortcut folder Trimble on Desktop. Shift right click on TrimbleVTS.exe

to start time keeper. Click Run as administrator. Click Show details > yes.
Minimize the Trimble VTS window.

(e) Make a directory to save the data. Click on Folder icon > Data (D:) > sync to Whi-
te Dwarf Archive > 20150124. Inside this folder, create sub-folders: bias, dark,
dome flat. Later on, we will create the directories for the targets.

(f) Click on the cactus icon (top right side) and click on Always Auto Scale for
best contrast.

Guide 82 computer controls the telescope.

(a) Click on icon Track82 ProEM. To start tracking the telescope, click on RA ON .
You can load an observing list as a text file and/or include new targets on the
right window.

Click on the coordinates of the target you want to observe. Go to the dome and
hold Shift and click on GO. If the telescope is too low or the target is too far from
the current position, you will have to manually move the telescope.

(b) Click on icon Guide82. To start getting images, you need to be on a target.

Your computer is not a requirement for your observing run, but if you have one,
you can use it to reduce the data and/or monitor the weather. Here are some useful
links:

http://observatories.hodar.com/mcdonald/night.html

http://weather.as.utexas.edu

And some data can be obtained at:

http://weather.as.utexas.edu/cgi-bin/latest 5min.cgi

This is the ip address of the official weather station of McDonald Observatory. In
cloudy nights, you can check this website in the comfort of your bed. It will tell you if
you can open the dome or not.

3. Setting up the instrument

Between the camera and the telescope, there is a filter wheel. If you are not sure of
which filter position is the BG40 filter, you may open it up on the East-side and look.
There is only a small screw to be removed by hand and the cover will come off.

On the West-side, there is a pin. By pushing it in, you block the light path into the
detector. That is the dark position.

4. Calibrations

You will probably want to do the calibrations before dinner, even if the forecast is not
very promising. If you run into troubles, the day crew will still be around to give you
a hand.
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(a) Bias frames: mirror covered, filter box aperture closed (push brass knob in), all
lights off.

Exposure time: 0s, Number of frames: 31, File name: bias, Save In:

D:\sync to White Dwarf Archive\YYYYMMDD\bias (click on the ... icon above
the Filename).

Shutter mode always closed.

Click 1 to run once or Run to make forever. When you are happy, click Acquire.
It will stop after 31 frames.

(b) Dark frames: mirror covered, filter box aperture closed (push brass knob in), all
lights off.

Exposure time: 29.998s, Number of frames: 31, File name: dark 30s, Save In:

D:\sync to White Dwarf Archive\YYYYMMDD\dark

Click 1 to run once or Run to make forever. When you are happy, click Acquire.
It will stop after 31 frames.

(c) Dome Flats: open mirror cover, extend the baffle tube, move filter box aperture to
filter (pull brass knob out), move the telescope to 0 HA and -40 RA, dome facing
East. Turn on the flat Variac lamp to count about 27 000 ADU.

Exposure time: 2.998s, Number of frames: 31, File name: dome flat BG40, Save
In:

D:\sync to White Dwarf Archive\YYYYMMDD\dome flat

Click 1 to run once or Run to make forever. When you are happy, click Acquire.
It will stop after 31 frames.

5. Opening the dome

After dinner, if the weather is fine, you can start cooling down the dome. Open the
east doors, raise the upper curtain, open the dome, the mirror cover and extend the
baffle tube.

There are some cases where you cannot open the dome: high humidity, high winds,
and/or high particle count. For humidity above 90%, you should check for condensation
inside the dome, but above 95% you must close. For particle counts between 50 000
and 100 000, you have to monitor the conditions with the powerful flashlight, checking
if it is possible to see big particles across the beam. Above 100 000 counts, you should
close immediately. Follow the instructions about wind in the weather monitor. There
are some intermediate situations, but the safest thing is to open only when the weather
conditions are stable for about half an hour. You probably do not want to damage
the telescope nor the instrument because of a little bit of data, which is probably
useless. Do not forget to notify the other observers if you close because of poor weather
conditions.

6. Zero-ing the telescope

Before moving the telescope, check the collision zones. Pay attention to the stairs, to
the wheels that move the curtains, and the instrument. Be very careful all the time!
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Choose a bright star close to the zenith (from The Astronomical Almanac) and type the
coordinates on Track82. Alternatively, on Track82, you can click on Setup (bottom
right) and select Zenith stars. A list of stars close to zenith will pop up. Select your
star. Turn on the RA tracking. Move the telescope to the target, using the flexed
coordinates, or click on Set Object for GO (top right) and holding Shift click on
GO. When you are happy, click on Setup and Update zeros.

It is recommended to do this procedure every night, but it is essential if some mainte-
nance has been done on the telescope during the day.

Now you are ready to go to your target! Type the coordinates in the same way as for
the bright star and move the telescope.

7. Focusing the telescope

You want the star to be as round and as small as possible. Change the exposure times
if the counts are too high or too low. It is recommended to focus either on your target
star or in a field nearby your target. On Track82, click on Focus. If you are on a
target, a window will pop up with a plot of FWHM as a function of focus encoder.
Change the value of the focus by clicking In or Out on Track 82. After acquiring
several values, click on the plot and a parabolic fit should provide you the best focus
value. You can delete wrong measurements by clicking on the plot.

But remember, if you are in doubt, your eyes will always provide the best least square
fit.

8. Actual observing

• Make sure RA tracking is ON.

• Create a sub-folder for the object in the current night folder.

• Set up LightField: Exposure times: (e.g.) 4.998 s, Number of frames: 9999 (or
a very large number),

File name: target name, Save In:

D:\sync to White Dwarf Archive\YYYYMMDD\target name

Naming Options: uncheck boxes, Shutter Mode: Always Open.

Click on Run then Acquire to save temporarily.

• Open a navigator (e.g. google chrome), create a new tab and type in https://git-

hub.com/ccd-utexas/tsphot/wiki/. To start an IPython Dashboard, on Desk-
top, open Windows Power Shell, execute ipython notebook. To create a new
IPython Notebook from the Dashboard, click on Dashboard tab in Chrome, click
New Notebook.

• Autoguide script: In the IPython Notebook tab for autoguide, change the path
in the first line of the script to the current directory and target. Click on Kernel

and Restart. Click Shift-Enter in each one of the steps of the script.

This should send the images to Guide 82, if LightField is acquiring images.

• Start to guide on a star by clicking on Autoguide. Change the box width to a
value between 150 and 200. Place the guide box on the target. In the Guide Box

window, right-click to the place the cross on top of the guiding star.
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• When you are happy with the focus and the guiding, on LightField click on Stop

and then Acquire. You are officially observing.

9. Online reduction

(a) On LightField, make a small box around each star in the field, starting with
the target. Click on the lab beaker icon (top right corner) and select Show

Statistics. Record the location of the maximum.

(b) In the target directory, right-click New > Text document to create a new text file
called phot coords.txt. Type in

target x target y

comparison x comparison y

comparison x comparison y

(c) In Chrome, create a new tab and type in https://github.com/ccd-utexas/ts-

phot/wiki/Online-analysis. Click on online analysis.ipynb. To start an
IPython Dashboard, on Desktop, open Windows Power Shell, execute ipython

notebook. To create a new IPython Notebook from the Dashboard, click on
Dashboard tab in Chrome, click New Notebook.

(d) Online script: In the IPython Notebook tab in Chrome for the online reduction,
change the path in the first line of the script to the current directory and target.
Click on Kernel and Restart. Click Shift-Enter in each one of the steps of the
script.

(e) On the directory for your target, a file named lc.pdf will be continuously up-
dated. Drag that file to a tab in Chrome to view the online reduction. You need
to refresh this to see the most updated light curves and Fourier transforms.

Other files will also be created in the directory.

10. Create logs:

(a) Observation log: Copy the file Observing Log Template for LightField.log

from the directory Data (D:) to Data (D:)\sync to White Dwarf Archive\YYYY-
MMDD\target. Rename this file to TargetName YYYYMMDD.log. Double click on
this file to edit it.

(b) Timing log: Click on Start Menu > Control Panel > Shift-right click Domain

Time II Client, click Run as administrator > Yes. In Domain Time box,
click Drift > Raw Data. In the Notepad window, click on File > Save As > save
in the target directory of the night the file as DTC drift YYYYMMDDTHHMMSSZ.txt.

11. While observing:

Monitor the dome every 15-30 min to prevent occultation.

Check the focus every 2 hours. Use 125 ms increments to focus while taking data.

Monitor the weather. Remember to call the other observers when you close the dome.

12. Changing targets:
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(a) Check that the Domain Time Client drift data was saved.

(b) On LightField, click Stop.

(c) In Chrome, on the online reduction tab, click Kernel > Interrupt Kernel. Then
click Kernel > Restart.

(d) In Guide82, uncheck Autoguide. In Chrome, on the autoguide tab, click Kernel

> Interrupt Kernel. Then click Kernel > Restart.

13. End of the night:

(a) Export file SPE to fits: On LightField click on the Data tab > Export Data.

On the window that pops up, select Batch, click Add directory, select the direc-
tory of the night (YYYYMMDD) and check box Include all sub-directories.
Region of interest: all, Frames: all, Export to File Type: FITS (.fits), Ex-
port as: One File per ROI per frame, check box Include All Experiment

Information, Save Exported Files To: Source File’s Location.

Click Export

(b) Export file SPE to CSV: On LightField click on the Data tab > Export
Data.

On the window that pops up, select Batch, click Add directory, select the direc-
tory of the night (YYYYMMDD) and check box Include all sub-directories.
Region of interest: all, Frames: all, Export to File Type: CSV (.csv), Export
as: One File per ROI per frame, Layout: Table (one pixel per row, CSV
Columns: FTN, ESTS, EETS, Header labels: Long names, Exposure started unit:
seconds, Exposure started precision: All decimal places, Exposure ended unit:
Seconds, Exposure ended precision: All decimal places, Save Exported Files
To: Source File’s Location.

Click Export

(c) On LightField, change the temperature of the camera to the current air tempera-
ture. When the temperature reaches that value, power off the camera, then close
LightField.

(d) Proceed with normal shutdown for 2.1 m telescope. Close the dome, lower the
upper curtain, close the mirror cover and the baffle tube, bring the telescope to
0 HA and -20 DEC, park dome slit East, power off the telescope.

(e) Back up files:

On Desktop, click on WinSCP. login: lonestar.tacc.utexas.edu, Portnumber: 22,
Username: ccd, Password: xxx, click login.

The left side is for the local files (D:\sync to White Dwarf Archive) and the right
side is the remote session (/home1/02109/ccd/Shortcut to White Dwarf Archive-

/ProEM 1024B). On the top left side, click on Synchronize.

Local directory: D:\sync to White Dwarf Archive, Remote directory: /home1-

/02109/ccd/Shortcut to White Dwarf Archive ProEM 1024B, Direction/Target
directory: Remote, Mode: Synchronize files, Synchronize options: Preview changes,
Comparison criteria: File size. Click OK.

Review synchronization checklist. Select only directories to synchronize.
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Now you can go to bed, because tomorrow is another day (or night)!
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